Back to overview
Degraded
Mailserver cannot respond to some emails
Apr 04 at 02:55pm BST
Affected services
ItsMeMailserver
Resolved
Jun 08 at 09:07pm BST
will be fixed in coming weeks by server transfer
Affected services
ItsMeMailserver
Updated
Apr 04 at 02:59pm BST
I am waiting for a response from Microsoft.
Affected services
ItsMeMailserver
Created
Apr 04 at 02:55pm BST
My mailserver is currently experiencing issues with sending mail to "@hotmail.com"/"@outlook.com" emails.
I am currently working with Microsoft, Digital Ocean and myself to fix this and it will take a undetermined amount of time to fix.
Please note if you email me from one of these I may not be able to respond.
Affected services
ItsMeMailserver